Using Zend Guard Loader

You can use Zend Guard Loader, a free application, to decode your website's Zend files if you use PHP 5.3 or later on your Linux hosting account. For more information, see View or change your PHP version.

Note: If you use any version of PHP prior to 5.3 (for example, 5.2), you must use Zend Optimizer to decode your Zend files. For more information, see Using Zend Optimizer.

Warning: Our Web/Classic accounts do not support Zend Guard 6.0 Currently, we only support Zend Guard 5.5.0.

To enable Zend Guard Loader, you must either modify or create a PHP initialization file (more info) that includes the following code at the beginning:

apc.enabled=0
[Zend]
zend_extension="/usr/local/Zend/lib/Guard-5.5.0/php-5.3.x/ZendGuardLoader.so"

The line apc.enabled=0 disables APC, which you must do to you Zend Guard on our hosting accounts.

Warning: We strongly suggest not using Zend Guard unless you know your files are encoded for PHP 5.3 or later. Files encoded with older versions of Zend Guard will not run under these version of PHP, and trying to decode those files on your hosting account can corrupt them.

Помогла ли вам эта статья?
Благодарим вас за отзыв. Чтобы связаться с сотрудником службы поддержки клиентов, позвоните по номеру этой службы или воспользуйтесь опцией чата выше.
Мы рады вам помочь! У вас остались вопросы?
Приносим извинения. Расскажите нам, какие затруднения вы испытываете или почему рекомендованное решение не помогло устранить проблему.